No internet connection performance

Apr 18, 2012 at 8:55 AM

Hi Mark,

I have been doing some testing on my phone and emulator and it seems that when there is not internet connection available the performance of the application degrades quite a bit. However, if I turn 3G/Wifi back on, the performance issue resolves itself. When I remove the control and there is no internet connection, it all works okay. 

I'm not sure if you are able to replicate this on your side?

BTW, I'm using the 1.1 release from NuGet and the Ad that was being tested is MobFox.

Thanks
Mauro

Coordinator
Apr 18, 2012 at 9:09 AM

Hi Mauro,

I'm thinking about implementing this Work item http://wpunifiedad.codeplex.com/workitem/601

I haven't seen the trouble specifically with MobFox, but I do know that AdMob is even freezing the UI when the connection is slow. So either implementing the code you see in this workitem in the pages that have the adcontrol or fullfilling the workitem could resolve this.

HTH,

Mark Monster

Apr 18, 2012 at 9:42 AM

Hey Mark,

I have seen the freezing that you mention about with AdMob. I have done a little research into it and it seems that its an actual issue with the AdMob control itself. I have since stopped using it until it gets resolved (Google dont seem to worried on fixing this)

https://groups.google.com/forum/#!topic/google-admob-ads-sdk/5O7WyZ9-ZN0
http://stackoverflow.com/questions/8372511/admob-freezing-my-windows-phone-application

Not sure if this is the same thing that you/other people are seeing?

Regards,

Mauro 

Coordinator
Apr 18, 2012 at 9:58 AM

That's the AdMob issue. I've been thinking about rebuilding it, using a little bit of reflector and fixing things like.

- Freezing UI

- Custom build ApplicationBar to native ApplicationBar

- Support for right colors when app is themed.

 

But that's quite a lot of work.